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What should be kept in mind when importing a contact?

Which fields need to be completed in order for the import to work properly and what do I have to prepare in bexio so that the contact is imported smoothly?

When importing contact details into bexio, there are a few mandatory fields and special aspects that you should keep in mind. This report explains the mandatory fields and special aspects of importing contacts to simplify the process for you.

The mandatory fields

Contact

Mandatory fields

Only company contacts

Contact type, Name 1, contact partner

Only private contact (mandatory fields from "Only company contact" plus)

Form of address

Company contact with contact partner (mandatory fields from "Only company contact" plus)

Contact person 1 -form of address, -first name, -last name, -contact partner

Support recommendation (all mandatory fields of all contact types plus)

Category, address, postcode, city, country, phone, e-mail

Special aspects 

  • Contact persons for company contacts are entered after the company contact under Contact person 1, Contact person 2, Contact person 3, etc.
  • The contents of the "Category", "Sector", "Form of address", "Title", "Country" and "Language" fields must all be present prior to being imported into bexio. "Categories", "Sectors", "Forms of address" and "Titles" can be managed under "Settings - All settings - Master data".
  • The username of a user entered in bexio must be specified under "Contact partner".
  • If the following fields are left empty, the contents of the main contacts are imported: Contact person 1 -Category, -Sector, -Country, -Contact partner

 

Import error messages and their meanings

Error

Cause

Line 2 - Contact partner column - This is a mandatory field.

"contact partner" in line 2 is empty.

Line 6 - E-mail column - This entry is incorrect.

"E-mail" in line 6 is misspelled or contains spaces.

Line 9 - Contact person 2 category column - This entry is incorrect.

"Contact person 2 category" in line 9 does not exist.

If just one single entry in the Excel file created for the import contains an error, no contacts will be imported. That gives you an opportunity to rectify the errors and re-import the complete list into bexio.

Why can't I perform an import?

To find out why, read the article "Why can't I perform an import?"

Import template

 Our template must be used when importing contacts. You can find it under "Settings - Import/export - Contacts".

 

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